Gemfile.lockからGemfileを作ってくれるbundle-locker

この記事は、newsdict.hatenablog.jp から移設しました。

Rails で開発を進めていると bundle update を行ったとたんに動かないなんてことがある。Gemfileを作るときにバージョンを指定すればよい話だがそうもいかない場面もあるだろう。

そんな時に役立ったのが bundle-locker である

実行は、

$ bundle exec bundle-locker Gemfile

Gemfile.lockからバージョンを引っ張ってきてGemfileに書き込んでくれる。

※ 問題にあたっとき、Gemfile.lockからバージョンを取得して Gemfile にしてくれる スクリプトを書きかけてたけど https://rubygems.org を検索することを心がけよう・・・・orz

コメントを残す

メールアドレスが公開されることはありません。